luyanbo

1.原来unity版本是 5.6.5f1 spine动画 正常用 后来升级unity2017.4.30f1 后 spine运行库也升到了spine-unity-3.8 但原来的Skeleton Data Asset会出error如图1
2.我尝试重新导入 5.6.5f1时用的spine资源 XX.atlas.txt XX.json XX.png 就有了下边的提示 没有正常生成XX_SkeletonData.asset
从图2上提示看 说明原来的版本时3.5.46吗 (后接受的项目不太了解)

请问以上两点时升级后的3.8运行库和原来的spine资源版本不兼容问题吗
那原来5.6.5f1时的.spine project 还能继续用吗 得升级spine后 重新导出 XX.atlas.txt XX.json XX.png文件吗
У вас нет необходимых прав для просмотра вложений в этом сообщении.
luyanbo
  • Сообщения: 3

Harald

请注意,Spine-Unity运行时版本(例如3.8)必须与用于导出骨架文件的Spine Editor版本(例如3.8.62)匹配。 当主要+次要版本号不匹配(3.5 vs 3.8)时,由于格式不兼容,Unity中的导入将失败。
Please note that the Spine-Unity runtime version (e.g. 3.8) has to match the Spine Editor version (e.g. 3.8.62) which was used to export your skeleton files. When major+minor version numbers do not match (3.5 vs 3.8 ) as in your case, import in Unity will fail due to format incompatibility.

因此,如果要使用Spine-Unity运行时版本3.8,则必须从Spine 3.8重新导出资产。
请注意,您可以使用批处理导出通过命令行界面快速重新导出所有骨架:
Export - Spine User Guide: Command line
So if you want to use Spine-Unity runtime version 3.8, you have to reexport your assets from Spine 3.8.
Note that you can use batch-export to re-export all your skeletons quickly via the command line interface:
Export - Spine User Guide: Command line
Аватара пользователя
Harald

Harri
  • Сообщения: 1028

luyanbo

如果要使用Spine-Unity运行时版本3.8,则必须从Spine 3.8重新导出资产========>您好 那需要升级spine 3.5到 spine3.8吗 然后再从spine软件导出来 XX.atlas.txt XX.json XX.png 文件吗 必须得用到 原来的 3.5做的.spine project 原文件吗
luyanbo
  • Сообщения: 3

Harald

是的,您必须将Spine项目文件从3.5更新到3.8,只需在Spine的最新更新版本3.8中打开旧的3.5项目文件即可完成。 然后重新导出XX.atlas.txt,XX.json和XX.png文件。
Yes, you have to update the Spine project file from 3.5 to 3.8, this is done by simply opening the old 3.5 project file in the latest updated version 3.8 of Spine. Then reexport the XX.atlas.txt, XX.json and XX.png files.

如果我误解了您的问题,请重新提问并重新发布。
If I misunderstood your question, please rephrase the question and post it again.
Аватара пользователя
Harald

Harri
  • Сообщения: 1028

luyanbo

非常感谢 明白了 !!
luyanbo
  • Сообщения: 3

Harald

别客气!
You're welcome!

我们目前正在努力提供更好的错误消息和信息框,以使版本不匹配问题更加明显。
We are currently working on providing better error messages and info boxes to make version mismatch problems more obvious to see.
Аватара пользователя
Harald

Harri
  • Сообщения: 1028


Вернуться в 中国Spine用户