Mari

Hello there,
I am currently testing the Trial Version of Spine and for now I do like it very much.

Now an "unexpected error" has occurred.

I created some bones with slots and skins, and animated them, but now it frequently shuts down whenever I want to select a bone in the sceletontree while being in setup-mode.
I am clueless and wonder if this is a known bug or an local failure?
It says jvm.dll is missing
Can you help me please? I tried installing JDK/JRE but it didn't solved the problem.
I add the logfile and a screenshot of the Error Message.
Thank you!

Mari

The spine.log:

Spine Launcher 1.4.9-trial
Windows 7 x86 6.1
Java 1.7.0-u6-unofficial Oracle Corporation
OpenJDK Server VM
Up to date: 1.5.26
Spine 1.5.26-trial, LWJGL
ATI Technologies Inc.
ATI Radeon HD 5800 Series
4.2.12217 Compatibility Profile Context 12.104.0.0
Started.
Uncaught
java.lang.ClassCastException: vj cannot be cast to vf
at tk.J(SourceFile:579)
at vl.f(SourceFile:973)
at wp.d(SourceFile:308)
at ph.Y(SourceFile:636)
at pt.a(SourceFile:701)
at it.a(SourceFile:28)
at gd.a(SourceFile:167)
at gd.a(SourceFile:132)
at com.badlogic.gdx.scenes.scene2d.ui.Tree.D(SourceFile:167)
at ij.b(SourceFile:114)
at iv.b(SourceFile:82)
at gj.a(SourceFile:57)
at gl.b(SourceFile:329)
at l.b(SourceFile:94)
at bd.d(SourceFile:297)
at aq.run(SourceFile:228)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:711)
at java.awt.EventQueue.access$000(EventQueue.java:104)
at java.awt.EventQueue$3.run(EventQueue.java:672)
at java.awt.EventQueue$3.run(EventQueue.java:670)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:681)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)
Mari
  • Сообщения: 3

Nate

Thanks for the report! I will do an update in a few minutes that fixes this.
Аватара пользователя
Nate

Nate
  • Сообщения: 9288

Nate

Ok, this should be fixed in 1.5.27, which is now up.
Аватара пользователя
Nate

Nate
  • Сообщения: 9288

Mari

Thank you very much. After the update it did perfectly work.
I'm so glad about it! Now I can continue testing that awesome tool.
Thanks a lot for your support.
^-^
Mari
  • Сообщения: 3


Вернуться в Bugs