Nemja

Hello everyone!

I made the classic error of working in too new version of Spine. I made 2 animations in 3.8.72 but I need them to work in 3.6.53. Can anyone help me with this?


The import data function doesn't work and neither does the JsonRollback trick. The terminal keeps telling me "com.esotericsoftware.spine.JsonRollback' is not recognized as an internal or external command,"

please help!
Nemja
  • Сообщения: 2

Erikari

Please try the method described here: open spine animation in to previous version
And make sure to have java installed, and to run the terminal from the correct folder (:
Аватара пользователя
Erikari

Erikari
  • Сообщения: 1983

Nemja

Thank you! It took some work, but your information saved me hours of damage control.

for anyone who needs this information I'll post my observations below:

The fix provided above was able to give me a JSON that worked in the various Spine 3.7's. It wasn't a perfect rollback. My animation used only transform, scale, rotate, graphs and alpha, but all scale parameters set to "1.0" were turned to "0.0" and some graphs for the transforms were wildly off from what I originally had keyed.

My solution to this was to open my finished animation in 3.8.72 and screenrecord me clicking on every transform and scale key to reveal its parameters. I then opened my messed up 3.7 version and made the keys match using the video as a reference.

Once the animation perfectly matched my original, I exported the JSON, got Spine to open in 3.6.53, imported the data and saved it!

I hope that info helps someone. My request to Esoteric is please add a "save as previous version" option to your JSON export. That would really help us :D
Nemja
  • Сообщения: 2


Вернуться в Editor