Tomateche

Hi,
I notice something tonight:

when images are in a slot, all their names becomes "_drag", and all the slots' names are "_drag,drag2, drag3..."
I suppose (hope) it's a bug.

Thanks for your great tool. :yes:
Tomateche
  • Сообщения: 8

jllust

Yes, confirmed here to. Any new image brought out from the images foldout, are defaulting to "__drag"
The image, though shown in the view is also named "__drag" and not mirroring the path resulting in the image icon to display red as if not yet used. v.1.6.35
jllust

Kickstarter Backer
  • Сообщения: 34

Tomateche

...and when I drag an image in an existing slot : Popup opens but checking " existing slot" make Spine crash.
Tomateche
  • Сообщения: 8

Nate

All issues mentioned about happened in 1.6.34 and were fixed within a few hours in 1.6.35. Can someone verity? I don't see it happening with 1.6.35.
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Tomateche

Same problems on 1.6.35 Essential edition on Mac

Edit
...and more (i'm sorry to seem so unpleasant :S

When multiple images are dragged on stage at the same time, only the last of the list appears, although all slots are created in the tree. Yet the slider reveals the silhouettes of other items on the stage. All are red in the tree.
Because of that, create new bones is impossible : the image glue to the parent bone whereas its silhouette selection stay in place....
in brief, it's unusable for the moment.

Hope you will fix it easily and quickly

Regards

Spine Launcher 1.5.1-full
____________________
Mac OS X x86_64 10.6.8
Java 1.7.0-u6-unofficial Oracle Corporation
OpenJDK 64-Bit Server VM
Up to date: 1.6.35
Spine 1.6.35-full, JGLFW
ATI Technologies Inc.
ATI Radeon HD 4850 OpenGL Engine
2.1 ATI-1.6.36
Started.
Uncaught
lu: index must be >= -1 and < 0: 0
at com.badlogic.gdx.scenes.scene2d.ui.List.a(SourceFile:149)
at ie.b(SourceFile:283)
at id.a(SourceFile:81)
at gw.a(SourceFile:55)
at gq.a(SourceFile:165)
at gq.a(SourceFile:130)
at gy.a(SourceFile:277)
at m.a(SourceFile:88)
at be.a(SourceFile:81)
at ap.e(SourceFile:209)
at rh.e(SourceFile:155)
at au.run(SourceFile:187)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:711)
at java.awt.EventQueue.access$000(EventQueue.java:104)
at java.awt.EventQueue$3.run(EventQueue.java:672)
at java.awt.EventQueue$3.run(EventQueue.java:670)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:681)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)
Tomateche
  • Сообщения: 8

Nate

Ah, I see. I fixed dragging images to bones and slots, but not dragging into the editor. This is why bug reports need reproduction steps! :)

Edit: fixed in 1.6.36, now available.
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Tomateche

:yes:
Tomateche
  • Сообщения: 8


Вернуться в Bugs