droptimal

Never seen this error before, but it has come up on separate projects very recently. What is the nature of this error and is it a result of an update? I cant seem to find any info on what this pertains to.
droptimal
  • Сообщения: 19

Nate

I guess it happens when you are packing a texture atlas? What version of Spine are you using? Is it possible to send the .spine project file and images so we can reproduce the problem? contact@esotericsoftware.com We will not share your IP with anyone and will delete it after reproducing and fixing the problem.
Аватара пользователя
Nate

Nate
  • Сообщения: 9264

droptimal

Yes. It happens with meshes weighted to bones.

v3.8.08-beta

I'll see about emailing it, I might not be able to for NDA reasons.
droptimal
  • Сообщения: 19

Nate

Thanks, we are anxious to fix this! 3.8 has had recent improvements to the texture packer. I don't see a problem, for example, packing spineboy images. The problem might require specific images and/or texture packer settings. Are you packing during JSON or binary data export? Are you using the new polygon packing?

If you can send your .spine file and images, we'll have your packer settings from the project, otherwise if you can post a screenshot of the settings dialog that may help (though without the images we may not be able to reproduce the problem). Worst case maybe you can black out the images (but keep the alpha), though of course you don't want to waste much time preparing the images.
Аватара пользователя
Nate

Nate
  • Сообщения: 9264

droptimal

Ok a sample has been sent to email. There have been 3 confirmed issues with this within the last week on different files.
droptimal
  • Сообщения: 19

pzey0625

Feels familiar, we had something similar with 3.7, but it was fixed back then:
Scaling + strip whitespace doesn't work in 3.7.81

Maybe something snuck back in in 3.8?
pzey0625
  • Сообщения: 7

Nate

Thanks for the project. pzey0625 is right, we have been able to reproduce the problem when using texture packer scaling and we are preparing a fix!

---

Fixed in 3.8.09-beta, available now!
Аватара пользователя
Nate

Nate
  • Сообщения: 9264

droptimal

.09 update fixed it. thanks!
droptimal
  • Сообщения: 19

AnnaB

This bug is not fixed for me in 3.8.11
Have double checked the texture sizes, they are all fine- in addition, the error disappeared when I reverted to 3.7.81
AnnaB
  • Сообщения: 6

Nate

Sorry you are having trouble, AnnaB. Is it possible to send images and the settings you use so we can see the problem? contact@esotericsoftware.com
Аватара пользователя
Nate

Nate
  • Сообщения: 9264

AnnaB

Hey there, here are the settings I am using. These settings worked fine in all previous versions. Thanks!
У вас нет необходимых прав для просмотра вложений в этом сообщении.
AnnaB
  • Сообщения: 6

Erikari

Hello Anna! I tried to use your settings but encountered no problems, could you send us the files over to contact@esotericsoftware.com to check?
My guess is that having those 4 pixels added on each edge for every image plus around the edge of the atlas your images might have been to large, but I'd like to verify it :> thank you!
Аватара пользователя
Erikari

Erikari
  • Сообщения: 1983

AnnaB

Hi there Erikari,
I can't send you the scene file because I'm working under an NDA, unfortunately.
However, the problem is definitely not in the settings. I am able to export the same scene perfectly fine with those exact settings in 3.7.93 (which I've reverted to), but NOT in 3.8.11.

---

Oh, also I can tell you that the images in my scene are sourced from a single PSD, and its dimensions are 768x1874 pixels, and there is very little overlap in the images (some extra hand variations and some overlap at joints) . So there is simply no way that the atlas would end up being over 2048x2048 pixels unless there is a packing error. 4 px per edge certainly would not make a difference :)
AnnaB
  • Сообщения: 6

Nate

If the padding was a problem, the error would be different -- it was a bad guess.

We've reproduced the problem and should have a fix for 3.7.94 soon! For now if you can pack with a scale of 1 or 0.5, you shouldn't see the problem.
Аватара пользователя
Nate

Nate
  • Сообщения: 9264

AnnaB

Great thanks- although, again, I should clarify- I do NOT have this issue in any 3.7 version- it's only coming up in 3.8 scenes.
AnnaB
  • Сообщения: 6

Nate

Ah yeah, I understood but mistyped. We've got it fixed in 3.8.12-beta. Unfortunately it may be a few days until we can do a release, as there are some big new features (skin bones and constraints!).
Аватара пользователя
Nate

Nate
  • Сообщения: 9264


Вернуться в Bugs