PinkpearlZ

Hi!
I'm creating a moving click point depends on levels for my mobile game.
But when I export it and run it with Unity then weird white glitch shows up and I don't know how to fix. Unity didn't report any error at all.
I upload my Spine's setting and a picture showing the error.
Please help me to fix this
У вас нет необходимых прав для просмотра вложений в этом сообщении.
PinkpearlZ
  • Сообщения: 3

Harald

We are sorry for the trouble! Are you using the latest spine-unity runtime unitypackage? A bug has previously been fixed in regards to default setup of imported textures and materials, you might want to install it to save you from future trouble.

Most likely the settings on the atlas texture asset are incorrectly setup. Please make sure to have the settings described in the spine-unity runtime documentation pages applied at the Texture and material when using atlas textures with default Premultiply alpha setting:
spine-unity Runtime Documentation: Advanced Premultiplied vs Straight Alpha Import
Аватара пользователя
Harald

Harri
  • Сообщения: 1105

PinkpearlZ

But is there any chance that my work on Unity will run into error after I install the newest version of Spine-unity runtime unitypackage ?

---

Harald писал(а):We are sorry for the trouble! Are you using the latest spine-unity runtime unitypackage? A bug has previously been fixed in regards to default setup of imported textures and materials, you might want to install it to save you from future trouble.

Most likely the settings on the atlas texture asset are incorrectly setup. Please make sure to have the settings described in the spine-unity runtime documentation pages applied at the Texture and material when using atlas textures with default Premultiply alpha setting:
spine-unity Runtime Documentation: Advanced Premultiplied vs Straight Alpha Import
I've just installed the Spine-unity 3.8 (updated 2019-10-31, changelog), recheck and make sure Correct Texture Packer export and Texture and Material import settings r just like the guide but still .. nothing better
PinkpearlZ
  • Сообщения: 3

Harald

If they have been imported already, the texture settings will not be overwritten by updating the spine-unity runtime. Could you try placing the three exported assets in a new directory and check if it is then correctly imported?

If it still does not work, could you please post a screenshot of your atlas texture and material import settings (the Inspector)?
Аватара пользователя
Harald

Harri
  • Сообщения: 1105

PinkpearlZ

Harald писал(а):If they have been imported already, the texture settings will not be overwritten by updating the spine-unity runtime. Could you try placing the three exported assets in a new directory and check if it is then correctly imported?

If it still does not work, could you please post a screenshot of your atlas texture and material import settings (the Inspector)?
Well that works! Thank you so much for helping
PinkpearlZ
  • Сообщения: 3

Harald

Glad to hear, thanks for letting us know.
Аватара пользователя
Harald

Harri
  • Сообщения: 1105


Вернуться в Unity