IndieDoroid

Hi

Unity seems to have trouble updating my latest animations.

I tried re-exporting the spine files a couple times now and still no luck.

The animator controller still uses the older animation even after I "Reload" from mecanim or "Force Update AnimationClips"

I can see the new time is exported into the skeletondata.asset, but it's not being updated in the controller. The older animation is 2+ seconds long, the new one is 1.7 seconds long
screenshot.74.jpg

screenshot.73.jpg

Any suggestions? :bigeyed:

3.8.76 pro
unity 2019.2.11f1

update
The way I got around it was to DELETE the animation from Spine and export that... This made sure Unity would update the animation controller... and then I UNDELETED the animation and re-exported back into Unity.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
IndieDoroid
  • Сообщения: 119

Harald

We are sorry for the trouble!

We encountered a similar problem in the past where state nodes inside the Animator window were not updating when Loop Time was changed in the referenced asset. As soon as any property of the state was changed (e.g. appending a letter to the name of the state), it updated correctly and respected the changes thereafter. Could you perhaps test if this works in your case as well?
Аватара пользователя
Harald

Harri
  • Сообщения: 1097

IndieDoroid

Harald писал(а):We are sorry for the trouble!

We encountered a similar problem in the past where state nodes inside the Animator window were not updating when Loop Time was changed in the referenced asset. As soon as any property of the state was changed (e.g. appending a letter to the name of the state), it updated correctly and respected the changes thereafter. Could you perhaps test if this works in your case as well?
Ok I'll try the renaming trick next time I run into this issue.
Аватара пользователя
IndieDoroid
  • Сообщения: 119


Вернуться в Unity