overcrafted

I am not sure if this is a spine error or an unity issue. So basically I am just doing what I have done dozens of times before when importing my characters to unity. The only difference is that I am now using unity 2019 and before I have used 2018

I export my spine project as json. This outputs 3 files. Then I import these files to unity. Since the spine plugin (http://esotericsoftware.com/spine-unity-download) tries to create all the necessary files unity crashes here as I import.

The error message from Unity is
guid is uninitialized.
UnityEditorInternal.InternalEditorUtility:ProjectWindowDrag(HierarchyProperty,Boolean)
UnityEngine.GUIUtility:ProcessEvent(Int32,IntPtr)
Is there a way to fix this issue? What can I do?
overcrafted
  • Сообщения: 3

Harald

We are sorry that you are facing problems. Which version of Uniy 2019 are you using?
Which versions of Spine and the Spine-Unity runtime?
Аватара пользователя
Harald

Harri
  • Сообщения: 1054

overcrafted

Hi thanks for reaching out

Spine 3.8.52
Spine-Unity runtime 3.7
Unity 2019.3.0a2
overcrafted
  • Сообщения: 3

Harald

overcrafted писал(а):Spine 3.8.52
Spine-Unity runtime 3.7
Please note that the Spine-Unity runtime version (e.g. 3.7) has to match the Spine Editor version (e.g. 3.7.93) which was used to export your skeleton files. When major+minor version numbers do not match (3.7 vs 3.8 ) as in your case, import in Unity will fail due to format incompatibility.

You can use batch-export to re-export all your skeletons quickly via the command line interface:
Export - Spine User Guide: Command line
Аватара пользователя
Harald

Harri
  • Сообщения: 1054

overcrafted

Got it, that makes perfect sense..
However I tried with spine-unity runtime version 3.8 and it still didn't work.

I then reinstalled unity. The version I am using now is 2019.2 because the previous version I was using had the tag "alpha" on it.
That seemed to solve the crash issue but this time it prompts a dialog saying "Could not automatically set the AtlasAsset". Of course I tried to set it manually afterwards but that didn't solve it either.

And when I put the skeletondata asset on the slot for skeletonanimation it outputs error message that the skeletondata has error.

I am not doing anything different than before. What has changed are the versions of spine and unity. If I give you one of my projects would you be able to check out what I am doing wrong so I can fix the other projects?
overcrafted
  • Сообщения: 3

Harald

We have not yet encountered this problem, but would be happy to receive your assets for testing! It would be great if you could send us a zip file containing a minimal project where this problem occurs, and send it to contact@esotericsoftware.com.

---

Thanks for the project files.

The asset in the json directory (skater boy.json) is exported with
"spine": "3.7.80-beta",
so this will throw errors upon import in the latest Spine-Unity 3.8 runtimes.

I have re-exported the asset from your included project files from Spine 3.8.54-beta and they were successfulyl imported in both Unity 2017.1 and Unity 2019.2 with the latest Spine Unity 3.8 runtimes.

Can it be that you have been using an old version of Spine 3.8-beta? You can check/change your Spine version via Spine -> Settings -> Application -> Version.
Аватара пользователя
Harald

Harri
  • Сообщения: 1054


Вернуться в Unity