Antidamage

Hey guys

Our animator used some spline tracks to animate some things that move around, and in 3.8 they simply stopped working in UE.

Is there something extra we have to do to get them to work again?
Antidamage
  • Сообщения: 27

badlogic

I'm afraid that's not enough information (btw, it's called Spine, not Spline :)).

What version of the Spine Editor did your animator export the files from? The runtimes and editor versions must match.

Can you post the exported files including atlases and tell me which animations do not work anymore?
Аватара пользователя
badlogic

Mario
  • Сообщения: 2108

Antidamage

A spline is a curved path, such as what I'm talking about. :)

I exported them, from whatever the latest 3.8 beta release is. The runtime is also 3.8.

I can upload them somewhere, can I PM you with the link?
Antidamage
  • Сообщения: 27

badlogic

Haha, now I look stupid regarding Spine/spline :p

I got your link via DM, I'm looking into it.
Аватара пользователя
badlogic

Mario
  • Сообщения: 2108

Antidamage

Thanks buddy. :)

I actually learnt the other day where the word spline comes from. It's a recent mathematical term short for Special Line. How goofy is that?

Another thought is that I haven't updated my runtime since moving to 3.8. I've made a few changes to fix warnings about properties being occluded which is making me reluctant to update. Could it be that?
Antidamage
  • Сообщения: 27

badlogic

Yeah, that is possible if you used one of the 3.8-betas. I haven't found time to look into it yet. I'll update this thread once I have more info for you.
Аватара пользователя
badlogic

Mario
  • Сообщения: 2108

badlogic

Sorry for the late reply, I fell sick last week. I now had time to look into this. Using the latest spine-ue4 AND spine-cpp from the 3.8 branch, animation3 of the project you send me per DM works as intended. Please make sure you also upgraded your spine-cpp copy, not just spine-ue4.
Аватара пользователя
badlogic

Mario
  • Сообщения: 2108


Вернуться в Runtimes