efrost

I just purchased the license for Spine Pro and downloaded the application. It wouldn't open, so I tried uninstalling the Trial software and restarting my computer. It still won't open. I'm not running any other programs other than an IM app and my internet browser. I need Spine for work. Is there any way I can resolve this quickly?
efrost
  • Сообщения: 3

Nate

Sorry you are having trouble. What happens when you run Spine? Does a window appear? What OS are you using? Does Spine show up in Task Manager (if you are on Windows)? If you are on OS X, please try closing other apps, as some applications interfere with Spine. Please post your spine.log file, if one is created:

Windows: <user home folder>\Spine\spine.log
Mac: <user home folder>/Library/Application Support/Spine/spine.log
Linux: <user home folder>/.spine/spine.log
Аватара пользователя
Nate

Nate
  • Сообщения: 9288

efrost

The icon blips for a second, but no window opens, and no tab is created for the program. My coworkers are able to run various applications along with Spine without issue. Will having the Trial application on my computer prevent Spine from running? I couldn't find an uninstall option so i just deleted the files, and I wasn't sure if that actually removed the app from my computer.

I wasn't able to find anything using the root you listed but i did find this:

Last login: Tue Dec 4 16:52:52 on ttys000
/Applications/Spine/Spine.app/Contents/MacOS/Spine ; exit;
Interns-MacBook-Air-2:~ intern$ /Applications/Spine/Spine.app/Contents/MacOS/Spine ; exit;
<JAVA_HOME>/lib/ext exists, extensions mechanism no longer supported; Use -classpath instead.
.2018-12-04 16:57:13.160 Spine[2141:81179] Unable to create Java VM, error: -1
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Process completed]


Is this helpful?
efrost
  • Сообщения: 3

Nate

So, OS X then. What version of OS X are you using? Please try closing other programs, eg Default Folder X causes Spine to hang and Rescue Time needs to be closed when Spine is started.

The trial does not interfere with the full version. Were you able to run the trial successfully in the past?

Note to run from the command line you can use just (don't need ; exit;):
/Applications/Spine/Spine.app/Contents/MacOS/Spine
Please try opening Console.app, clear it, then run Spine (clicking the icon is fine) and post everything that appears in the Console, just in case that gives us anything more.

The log does help, a little, thanks. Unfortunately it's still not clear why Java cannot initialize. :( Spine does not use the system Java at all, it has its own copy. The message about /lib/ext is odd, it should not care about JAVA_HOME. Please try this:
JAVA_HOME=/asdf
export JAVA_HOME
/Applications/Spine/Spine.app/Contents/MacOS/Spine
Where /asdf is some folder that does not exist.
Аватара пользователя
Nate

Nate
  • Сообщения: 9288

efrost

This is what was reported in the Console.app after i cleared it and tried to activate Spine:

default 10:59:30.932845 -0500 CommCenter #I handleLSNotitifcation_sync: Application launched: <private>
default 10:59:30.940229 -0500 taskgated MacOS error: -67062
default 10:59:30.946445 -0500 WacomTabletDriver handleNotification:com.apple.sharedfilelist.change
default 10:59:30.954173 -0500 mds directQueryFetchResultsReply 81923 1795162112 35
default 10:59:30.954661 -0500 mds directQueryFetchResultsReply 81921 1795162112 35
default 10:59:30.974022 -0500 launchservicesd UNIX error exception: 22
default 10:59:30.983384 -0500 launchservicesd MacOS error: -67062
default 10:59:30.986879 -0500 launchservicesd CHECKIN:0x0-0x42042 1122 (null)
default 10:59:31.107504 -0500 loginwindow lux 39.000000, ambient 0.528857, <private>
default 10:59:31.107541 -0500 loginwindow setting canAdjust from 1 to 1
default 10:59:31.107572 -0500 loginwindow brightness 0.52886 _ambientOffset = 0.40000 final (to be capped) = 0.92886
default 10:59:31.107599 -0500 loginwindow PWM value = 3814 speed = 500
default 10:59:31.108046 -0500 loginwindow changed brightness to 0.928857. <private>
default 10:59:31.120346 -0500 CommCenter #I handleLSNotitifcation_sync: Application exited: <private>
default 10:59:31.704500 -0500 loginwindow lux 29.000000, ambient 0.446000, <private>
default 10:59:31.704567 -0500 loginwindow setting canAdjust from 1 to 1
default 10:59:31.704616 -0500 loginwindow brightness 0.44600 _ambientOffset = 0.40000 final (to be capped) = 0.84600
default 10:59:31.704656 -0500 loginwindow PWM value = 3492 speed = 500
default 10:59:31.705022 -0500 loginwindow changed brightness to 0.846000. <private>
default 10:59:32.102841 -0500 loginwindow lux 34.000000, ambient 0.487429, <private>
default 10:59:32.102932 -0500 loginwindow setting canAdjust from 1 to 1
default 10:59:32.103004 -0500 loginwindow brightness 0.48743 _ambientOffset = 0.40000 final (to be capped) = 0.88743
default 10:59:32.103069 -0500 loginwindow PWM value = 3653 speed = 500
default 10:59:32.103509 -0500 loginwindow changed brightness to 0.887429. <private>
default 10:59:33.097823 -0500 loginwindow lux 44.000000, ambient 0.570286, <private>
default 10:59:33.097894 -0500 loginwindow setting canAdjust from 1 to 1
default 10:59:33.097951 -0500 loginwindow brightness 0.57029 _ambientOffset = 0.40000 final (to be capped) = 0.97029
default 10:59:33.097999 -0500 loginwindow PWM value = 3975 speed = 500
default 10:59:33.098444 -0500 loginwindow changed brightness to 0.970286. <private>
default 10:59:33.519301 -0500 kernel + IOAudioDevice[<private>]idleAudioSleepHandlerTimer: pendingPowerState = 1, idleSleepDelayTime = 66fc23ac00
default 10:59:33.519324 -0500 kernel + IOAudioDevice[<private>]::initiatePowerStateChange(0x0) - current = 2 - pending = 1
default 10:59:33.520125 -0500 kernel + IOAudioDevice[<private>]::protectedCompletePowerStateChange() - current = 2 - pending = 1
default 10:59:33.520147 -0500 kernel - IOAudioDevice[<private>]::protectedCompletePowerStateChange() - current = 1 - pending = 1 returns 0x0
default 10:59:33.520159 -0500 kernel + IOAudioDevice[<private>]::protectedCompletePowerStateChange() - current = 1 - pending = 1
default 10:59:33.520163 -0500 kernel - IOAudioDevice[<private>]::protectedCompletePowerStateChange() - current = 1 - pending = 1 returns 0x0
default 10:59:33.520167 -0500 kernel - IOAudioDevice[<private>]::initiatePowerStateChange(0x0) - current = 1 - pending = 1 returns 0x0
default 10:59:33.520172 -0500 kernel - IOAudioDevice[<private>]idleAudioSleepHandlerTimer: pendingPowerState = 1, idleSleepDelayTime = 66fc23ac00
default 10:59:40.745124 -0500 AirPlayXPCHelper 2018-12-05 10:59:40.745040 AM ### Connect to 10.106.123.20 timed out
default 10:59:42.065034 -0500 trustd could not enable test hierarchy: no UAT pinning preferences set



Note: my OS is Mac High Sierra version 10
efrost
  • Сообщения: 3

Sergiy

All the same after update to 3.7 under OSX got error :bang: :bang: :bang: :
bash-3.2$ ./Spine
<JAVA_HOME>/lib/ext exists, extensions mechanism no longer supported; Use -classpath instead.
.2019-01-05 03:21:07.088 Spine[91439:7793089] Unable to create Java VM, error: -1
bash-3.2$ echo $JAVA_HOME
/Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home
bash-3.2$ uname
Darwin
bash-3.2$ pwd
/Applications/Spine/Spine.app/Contents/MacOS
PS: Proposal to bypass this error through workaround by re-exporting an incorrect environment variable seems not solution at all. Because in this case I need always run Spine via my custom script.
bash-3.2$ JAVA_HOME=/asdf
bash-3.2$ export JAVA_HOME
bash-3.2$ ./Spine
<JAVA_HOME>/lib/ext exists, extensions mechanism no longer supported; Use -classpath instead.
.2019-01-05 03:38:17.292 Spine[91654:7802280] Unable to create Java VM, error: -1
bash-3.2$ /Applications/Spine/Spine.app/Contents/MacOS/Spine
<JAVA_HOME>/lib/ext exists, extensions mechanism no longer supported; Use -classpath instead.
.2019-01-05 03:38:32.990 Spine[91656:7802448] Unable to create Java VM, error: -1
Importent update:
After I was removed the Spine folder via
sudo rm -rf /Application/Spine
and reinstalled the error was gone
Аватара пользователя
Sergiy
  • Сообщения: 8

Nate

Sorry for the trouble! We haven't seen such a problem, so it is very surprising. @Sergiy, you said reinstalling fixed it -- do you know what launcher version you had before you reinstalled?
Аватара пользователя
Nate

Nate
  • Сообщения: 9288

Sergiy

I do not know which one, but it was the current version at the time of download dated November 26, 2015. But I remembered here that the error appeared after I tried to install the trial version (because when you announced a stable version 3.7 today, I tried to update several times through a luncher but all my attempts were in vain, and then I tried to install a new trial version through the site). And after that the error began to appear. Unfortunately, I cannot provide a more detailed STR (steps to reproduce).
Аватара пользователя
Sergiy
  • Сообщения: 8


Вернуться в Bugs