eason

spine在预览工具里正常显示,但是导入到unity里不显示,请问有人知道吗,附件里是这个spine的资源,unity版本是2020.3.16f1
У вас нет необходимых прав для просмотра вложений в этом сообщении.
eason
  • Сообщения: 8

Misaki

您好。你需要把你的图集的扩展名改为.atlas.txt。如果不这样做,Unity将不能正确加载你的骨架。正确的导出设置在spine-unity运行时文档的以下部分有描述:
spine-unity 运行时文档: 从Spine导出文件到Unity
---
Hi, you need to change the extension of your atlas to .atlas.txt. If this is not done, Unity will not load your skeleton properly. The correct export settings are described in the following section of the spine-unity runtime documentation:
spine-unity 运行时文档: 从Spine导出文件到Unity
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755

eason

上面的附件是动效给的源文件,放到unity里是会处理一遍,改成你说的那种格式的
eason
  • Сообщения: 8

Misaki

我明白扩展的问题。然而,你的骨架在Unity中显示正确。这个骨架在Inspector窗口的预览中可能显示得不好,因为所有槽的混合模式都设置为Additive,但在场景中却很好。

I understand about the extension. However, your skeleton displays correctly in Unity. This skeleton may not display well in the preview of the Inspector window because the blend modes of all slots are set as Additive, but it is fine in the scene.
Screen Shot 2022-06-01 at 13.14.23.png

你能否检查一下Preferences 参数是否按照文件中的描述正确设置?

If it does not display on your end, it may be that the material settings are incorrect. Could you check to see if the Preferences parameters are set correctly as described in the document?
spine-unity 运行时文档: 高级 Premultiplied 和 Straight Alpha 导入
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755

eason

Misaki писал(а):我明白扩展的问题。然而,你的骨架在Unity中显示正确。这个骨架在Inspector窗口的预览中可能显示得不好,因为所有槽的混合模式都设置为Additive,但在场景中却很好。

I understand about the extension. However, your skeleton displays correctly in Unity. This skeleton may not display well in the preview of the Inspector window because the blend modes of all slots are set as Additive, but it is fine in the scene.
Screen Shot 2022-06-01 at 13.14.23.png

你能否检查一下Preferences 参数是否按照文件中的描述正确设置?

If it does not display on your end, it may be that the material settings are incorrect. Could you check to see if the Preferences parameters are set correctly as described in the document?
spine-unity 运行时文档: 高级 Premultiplied 和 Straight Alpha 导入
抱歉之前没看到你的回复,如果是SkeletonAnimation我这边也是能够正常显示的,但是如果是SkeletonGraphic的话就没法正常显示了
eason
  • Сообщения: 8

Misaki

你能不能把你的Unity场景项目发给我们,让我们看看你的骨架到底是怎么显示的?: contact@esotericsoftware.com

Could you please send us your Unity scene project so we can see exactly how you are displaying your skeleton?: contact@esotericsoftware.com
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755

eason

Misaki писал(а):你能不能把你的Unity场景项目发给我们,让我们看看你的骨架到底是怎么显示的?: contact@esotericsoftware.com

Could you please send us your Unity scene project so we can see exactly how you are displaying your skeleton?: contact@esotericsoftware.com
已经发送至你提供的邮箱啦,麻烦帮看下,感谢 :grinteeth:
eason
  • Сообщения: 8

Misaki

我刚刚回复了你,但不幸的是,我无法下载你附上的文件。你是否有可能通过其他方式将文件发送给我们?

I replied to your email a while ago, but unfortunately the download page shows an error message and I cannot download the file you attached. Could you send us the file via another way?
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755

eason

Misaki писал(а):我刚刚回复了你,但不幸的是,我无法下载你附上的文件。你是否有可能通过其他方式将文件发送给我们?

I replied to your email a while ago, but unfortunately the download page shows an error message and I cannot download the file you attached. Could you send us the file via another way?
https://cowtransfer.com/s/be59cd461a5e4a 到这下载试试
eason
  • Сообщения: 8

Misaki

谢谢你上传你的Unity项目,看来可以通过在SkeletonGraphic的CanvasRenderer组件中禁用Cull Transparent Mesh来解决。
Thank you for uploading your Unity project, it seems that it can be solved by disabling Cull Transparent Mesh at the SkeletonGraphic's CanvasRenderer component.
Cull-Transparent-Mesh.png

请参考Harald在本主题中的前一个答案。:
Please refer to Harald's previous answer in this thread:
Spine not showing on the UI
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755

eason

Misaki писал(а):谢谢你上传你的Unity项目,看来可以通过在SkeletonGraphic的CanvasRenderer组件中禁用Cull Transparent Mesh来解决。
Thank you for uploading your Unity project, it seems that it can be solved by disabling Cull Transparent Mesh at the SkeletonGraphic's CanvasRenderer component.
Cull-Transparent-Mesh.png

请参考Harald在本主题中的前一个答案。:
Please refer to Harald's previous answer in this thread:
Spine not showing on the UI
感谢,取消勾选后可以正常显示啦
eason
  • Сообщения: 8

Misaki

我很高兴听到你的问题已经得到解决! 谢谢你给我们回信。
I’m glad to hear your problem has been resolved! Thank you for getting back to us.
Аватара пользователя
Misaki

Misaki
  • Сообщения: 755


Вернуться в 中国Spine用户