Krøllebølle

There are some strange bugs occurring in the latest version (1.6.30) in Ubuntu. I haven't really been able to reproduce exactly when the bugs occur, but they happen after working for some time with a project. It seems that they usually happen together. The bugs always disappear when closing and reopening Spine, but come back after working for less than 5 minutes.

1. The hot keys stop working. I cannot for example not press ctrl+s to save, but using the mouse works fine.
2. When creating a new bone I select the parent bone and draw the new bone. Then the parent bone is moved and redrawn at the new position. No new bone is created.
3. Sometimes get caught in an infinite "loop" when first opening a project and then trying to open another. The dialog cannot find any spine project files and closing the dialog displays a text saying that I have to select a Spine project before the dialog is reopened. I have seen that the whole path to the current project is set as path at first when this happens.

I will update this thread if I can find some steps to reproduce the error.

Log file:
Spine Launcher 1.1.3-full
Licensed to: <snip>
Linux amd64 3.2.0-54-generic
Java 1.7.0-u6-unofficial Oracle Corporation
OpenJDK 64-Bit Server VM
Up to date: 1.6.30
Spine 1.6.30-full, LWJGL
NVIDIA Corporation
GeForce 8600M GT/PCIe/SSE2
3.3.0 NVIDIA 304.88
Started.
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Nate

2) This is the behavior when alt is held down. Sounds like a key has gotten stuck. Try pressing and releasing alt, ctrl, and shift on both sides of the keyboard, then see if it works. This could also explain #1. Are you using alt while working with Spine? Maybe it gets stuck when you alt+tab?

3) I will have to give this a try.
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Krøllebølle

Nate писал(а):2) This is the behavior when alt is held down. Sounds like a key has gotten stuck. Try pressing and releasing alt, ctrl, and shift on both sides of the keyboard, then see if it works. This could also explain #1. Are you using alt while working with Spine? Maybe it gets stuck when you alt+tab?
Yes, you are correct about the alt-tabbing. When alt-tabbing to another window and back the alt key is "stuck". It does not help pressing alt or ctrl, but pressing ctrl+alt fixes both the redrawing of the bone and the disabling of the hot keys. I would guess this has something to do with Ubuntu. It works okay for me to work around this by pressing ctrl+alt, but maybe you're able to figure out what's wrong ;)
Nate писал(а):3) I will have to give this a try.
I cannot reproduce this, not even with the alt key "stuck" as in the other parts, sorry. I will update if/when I stumble across this again.
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Nate

Well glad we have a workaround for 1+2, even though I imagine it is a bit annoying. :S
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Krøllebølle

Not sure what I did, but now I got caught in that loop again. In the two attached images you can see what happens. First I open the open file dialog (bug02) and the "Selection" text field contains the whole path. Neither Spine projects not any other files are shown, not when selecting "All files". If I press cancel or close the dialog I get back to Spine with the message "Please chose a ".project" file, not a directory." and when I press "Ok" here I get back to the first dialog again.

So there's some documentation. Don't know how to reproduce it :p (Though I'm pretty sure I used ctrl+o after first pressing ctrl+alt this time, which probably should not matter).
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Nate

Ok, I think I fixed it in the next version!
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Krøllebølle

An update on this one: It seems like the "loop" bug is gone, but I noticed one thing, however: If you look at the file dialog I attached, there is no possibility to select any files. It might be that the width of that GUI part is 0 or close to 0. When I open this dialog now I have this tiny, tiny part of selectable files in the current folder to the right. If I increase the width of it everything is fine. Dunno why it is like that, but perhaps you could just increase the width of it?

Hm, ok, the width of it was normal again after updating. Maybe you fixed it already ;) (and maybe I messed it up myself)
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Krøllebølle

I found a way to reproduce this:
1. Open Spine.
2. Open the open file dialog (ctrl+o). Close it.
3. Open the export dialog (ctrl+e) and press browse. A similar (the same?) dialog appears. Close it.
4. Open the open file dialog again (ctrl+o). Now the files part to the right is missing. Maybe width is set to 0?
5. Reopen Spine to fix the issue.
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Nate

Can you resize the headers with the mouse? I'm afraid I don't have control over that dialog. I can recreate it every time instead of reusing the same one, though that might make it slower to open.
Аватара пользователя
Nate

Nate
  • Сообщения: 9861

Krøllebølle

Yes, it is possible to resize the right part of the dialog even though the width is 0, but you have to know it's there in the first place. It works fine for me to do it like this, I don't export that often ;)
Krøllebølle

Kickstarter Backer
  • Сообщения: 36

Nate

Ok. I recreate the dialog each time in 1.6.37, hopefully that helps.
Аватара пользователя
Nate

Nate
  • Сообщения: 9861


Вернуться в Bugs