dechriss

Hello,
I keep getting this warning in Unity:
Problematic material setup at Spine GameObject (Name): Warning: Premultiply-alpha atlas textures not supported in Linear color space!

Please
a) re-export atlas as straight alpha texture with 'premultiply alpha' unchecked or
b) switch to Gamma color space via
Project Settings - Player - Other Settings - Color Space.
I did already uncheck the premultiply alpha when exporting from Spine.
I don't want to switch my project to Gamma color space.

How could I possible tackle this?


Unity 2019.2.0f1
Spine Package version: com.esotericsoftware.spine.lwrp-shaders-3.8-Unity2019.2-2019-08-13.zip
dechriss
  • Сообщения: 2

Harald

Sorry for the confusion! Please note that the warning is based on the material setup values, not the export settings that were used in Spine.
I will update the warning message to be more precise.

Please correct the Straight alpha parameter to true at your material if it was already exported as straight alpha without Premultiply alpha set.

---

I have now updated the warning message tex accordingly.

New unitypackages can be downloaded here as usual:
Spine Unity Download
Аватара пользователя
Harald

Harri
  • Сообщения: 1116


Вернуться в Runtimes