Naos

Hello,

I'm trying to set setup skins in advance with the PhotoshopToSpine script but encounter several problems.
I'm using the latest versions of Photoshop (v22.1.1) and of the script (v5.7). And the Spine beta(v4.0.53-beta).

With the PhotoshopToSpine v5.3 and v5.7:
My problem is that when I import my JSON file into Spine. It makes me attachments for every items even though the images of the skin have the same names.

Screenshot_8.png


Also, since I updated my PhotoshopToSpine script to the v5.7, the "[merge] body" images aren't generated in my Images folder.

Screenshot_9.png


I must be doing something badly and tried different things but can't find what it is. :detective:

Thanks in advance :)

---

Did a quick simplified setup to test the problem.

Screenshot_10.png


Screenshot_11.png


But I don't get the same result as in the tutorial video with the boy and girl skins. :think:
I would like to have just one "main" with the differents skins in it.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Naos
  • Сообщения: 1

nicmar

I think I have the exact same problem. I have a setup like this:
Skärmavbild 2021-01-27 kl. 10.49.51.png


And when I export i get only this:
Skärmavbild 2021-01-27 kl. 10.50.21.png


I tried with different names like [slot:eyes] and such, but it didn't help. With layers that are already merged, i don't even have to typ [slot] so there seems to be a problem with the merge tag.

I added the PSD-file that i'm trying to export so you can more easily debug it.
Is there old versions of the script anywhere so we can downgrade to a version that is working?

Thanks!

---

Update, i found the old versions on git, and 5.2 seems to work for me. Hope it helps :)
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Using Spine to make SpaceChef - The Taste of Trouble. A humoristic open world space western, featuring a chef with nothing to loose, after he loses everything.. ;) Follow our work on Twitter @BlueGooGames.
Аватара пользователя
nicmar
  • Сообщения: 79

sixus

I ran into the same problem as well - I tried an older version of the script (5.3) from Github and the merge problem doesn't happen with that.

Regarding the other issue mentioned by Naos - any help with that? I get similar results (different behaviour compared to the tutorials: a separate slot for each skin instead of one slot with skin placeholder attachment) and I don't really understand why that is. EDIT: I realized it needs the [slot] tags and then it works as expected, so user error this time :)
Аватара пользователя
sixus
  • Сообщения: 1

Søren

We will have a fix out for this very soon. Sorry for the trouble guys.

You can follow the progress on the fix here: https://github.com/EsotericSoftware/spine-editor/issues/585
Аватара пользователя
Søren

Shiu
  • Сообщения: 2440


Вернуться в Bugs