bjuglez

helpmee.png


Greetings.
Does anyone know whats going on here? I am using spine path constraints on the characters tail and it works for the purple one using skeleton utility -> spawn hierarchy -> follow bones.
Ive exhausted everything I can think of atm. Ive also checked if they are set up differently in spine or in unity as well but everything seems to be same.

both are exported into unity under 3.8 runtimes as well but the purple one might have been exported with a little older version of spine. Ill test that later since I need to make a backup for that which will take ages. Hoping someone has run into this before before I try that.

thanks.

---

Fixed, I tried for funsies to add an override to where the tail starts and now it works.
I think this has something to do with animation on body or root rotating which interrupts with this somehow?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
bjuglez
  • Сообщения: 2

Harald

A complete hierarchy of SkeletonUtilityBones in mode Follow should still work. Are you sure that you haven't changed (and re-exported) the skeleton after the hierarchy of SkeletonUtilityBones was generated?

Which version of the spine-unity runtime (name of the unitypackage, also mentioned in the version.txt file in the Spine directory) are you using?

If the problem persists when spawning a new hierarchy on a clean skeleton, could you perhaps send us your skeleton assets (the three exported files)? You can either attach them to a forum posting or send them as a zip package to contact@esotericsoftware.com. Then we can have a look at what's going wrong.
Аватара пользователя
Harald

Harri
  • Сообщения: 2761


Вернуться в Unity