TrantoS

Hi,
I'm sorry for this request but true is that I'm graphic artist more than programmer. ;)

I extracted Spine-Unity 3.7 runtime unitypackage into Unity 2018.3.4f1 project and now I have this error in Unity:

Assets/Spine/spine-unity/Modules/AnimationTools/AnimationTools.cs(215,6): error CS1501: No overload for method SetFrame' takes 4' arguments

I know that this Spine-Unity runtime isn't built for this version of Unity but please exist some easy way how can I fix it please?
TrantoS
  • Сообщения: 2

Harald

Sorry for the late reply! I guess you have extracted the Spine unitypackage over existing Spine files - can you please delete the AnimationTools.cs file, it was removed some time ago and seems like a left-over file from a previous unitypackage.

A question on the side - are you using Spine 3.7 and the Spine 3.7 Unity runtime?
Аватара пользователя
Harald

Harri
  • Сообщения: 1105

TrantoS

Thank you very much for your reply. Yes, I'm using Spine 3.7 and the Spine 3.7 Unity runtime. I cleaned my project and now all works perfectly. Thank you again.
TrantoS
  • Сообщения: 2

Harald

Perfect, thanks for the info!
Аватара пользователя
Harald

Harri
  • Сообщения: 1105


Вернуться в Bugs