mccxiv

Hello! I'm using Phaser, which I believe uses the official ts-spine underneath. I can't figure out how to disable linear filtering / anti-aliasing when scaling up the rendered object. :think:

Please see the attachment. On the left it's 1x and 3x, on the right it's what I want to achieve, running in the editor.

Any tips? I'm willing to do some hacky things if necessary. (Btw I've already enabled pixelArt mode on Phaser, but it doesn't apply to Spine items, I guess because Spine has its own rendering? Also added image-rendering: pixelated; CSS just in case)

---

A friendly person helped produce a repro (using Pixi): https://github.com/pixijs/pixi-spine/issues/375#issuecomment-781647959

Still no solution though

---

SOLVED!!!!

See this comment on GitHub, you have to change the filter at export time within Spine (I would have never guessed this)
У вас нет необходимых прав для просмотра вложений в этом сообщении.
mccxiv
  • Сообщения: 1


Вернуться в Runtimes