Bobsolo1

Hello. I wish to run the example for monogame c#. I followed the instructions on how to set up the example, but nothing happened. Can anyone here tell me what I'm doing wrong?
Bobsolo1
  • Сообщения: 5

Harald

Sorry to hear you are having troubles. We have just fixed a compile error for VS 2019 on the 4.0 branch, perhaps this prevented your build from completing? Please have a try pulling the latest changes and build your project again.

If this was not the problem, could you please describe in more detail (maybe with some screenshots as well) what you mean by "but nothing happened"? Are you sure you are having the example project set as the startup project (the project with the bold name, which will be executed when you hit F5 to run)?
Аватара пользователя
Harald

Harri
  • Сообщения: 3469

Bobsolo1

Maybe. But I did follow the instructions on how to run the example(coin, raptor, goblin, etc) and When I open those examples, the project showed unloaded and can't set it to debug. Any ideas?
Bobsolo1
  • Сообщения: 5

Harald

Sorry, having fixed the compile error just an hour earlier I jumped on this train too quickly, upon second reading I noticed that you want to use spine-monogame with a MonoGame version available for Visual Studio 2019.

Unfortunately the example project file, which has been created a long time ago, used Visual Studio 2015 and MonoGame 3.0, still listing the dependency for MonoGame 3.0 in the examples csproj file. Now Visual Studio 2019 (and IIRC also 2017) no longer supports MonoGame 3.0. Since MonoGame has been changed from a pre-installed package to being separately available (via NuGet or download), we would first need to adjust the example project accordingly, potentially fixing any problems due to breaking MonoGame changes. Before that, the example project will not load or build successfully.
Аватара пользователя
Harald

Harri
  • Сообщения: 3469

Bobsolo1

so just use the new one 4.0 from github?
Bobsolo1
  • Сообщения: 5

Harald

Which 4.0 version do you mean, as I don't know about a MonoGame version 4.0 (the latest MonoGame version seems to be 3.8)?
If you mean the Spine runtime version 4.0, then this will not help as it contains the same MonoGame 3.0 dependency and has not been updated yet.
Аватара пользователя
Harald

Harri
  • Сообщения: 3469


Вернуться в Runtimes