Jelligeth

Hi,

I've trawled through the forums already, as well as all the googles, but none of the recommended solutions are fixing this issue.

I'm still experiencing some trouble with updating the spine generated animator controller with both new and/or renamed clips. The weird thing is, when I removed the .txt from the extension after .json with the Unity update, it began working for a bit, but somehow it's stopped updating properly again, even though I've been consistently exporting without the .txt extension.

The clips are picking up on the skeletonData file, it just doesn't update the controller.
Pretty sure I've got the latest Unity updates, and I downloaded the runtimes from the Esoteric github link end of December, so I'm guessing those are the latest ones?

Help! :(

Jelligeth
  • Сообщения: 2

Pharan

The Mecanim importer hasn't been updated in months. But I don't think it was ever designed to handle when you rename animations because there's really no way to tell, and it would break your references if it did anything like delete old ones or just guess which one is which (which would kind of have insane implementation details), for example, if you had set them up in a state machine or reference in some other script.

Not too sure how that's supposed to work yet. Will point @Mitch to this thread.
Аватара пользователя
Pharan
  • Сообщения: 5366

Jelligeth

Thanks for the reply!
That makes sense, I was definitely trying my luck with the renaming, but new anim clips still weren't updating before I did any renaming...I think? I've tried changing the names back to what it was before but it hasn't fixed it, so not sure if the renaming broke it permanently, or if it's a problem somewhere else carrying over.

Is there a way to go into the spine generated controller and manually rename things to be more consistent? It doesn't let me rename in the project view, nor manually drag more clips in, but maybe if the naming consistency was restored it will start automatically updating again. :/

-- 08 Jan 2016, 14:30 --

Ok, so the re-renamed clips are working now, if I change the animation in Spine and export it, it does update within mecanim, so the connections are definitely not broken. The names are all consistent as well...it's just new clips that don't seem to get picked up in the spine generated animator. It does get included if I instantiate a new mecanim skeleton but I don't want to lose my state machine connections. I'm going to try
Jelligeth
  • Сообщения: 2

Rahel

So you're stopping caring about this issue ? There are two much older post about that situation already and there's still no solution? I had the issue before while the project was still young and had to re-do the controller because it suddenly stopped updating itself.
Now I have the same issue again. Everything worked well and suddenly without a tracable reason it doesn't. No matter if you just add or delete or re-name an animation - the mecanim controller doesn't care! I tried those three steps seperatly so Pharans suggestion isn't correct. It would be insane if I have work with two controllers. One being the actual controller and the other one just holding the anims I can replace all the time if new animations are created ..
Rahel
  • Сообщения: 6


Вернуться в Unity