alexramallo

Hi,

The new 4.0 release is great, but I didn't want to upgrade to it because I was worried about the runtime incompatibility. Well, today my 3.x editor refused to start, telling me it was out of date and I had to reinstall it. So I went to my license page and did that, but the only link there was for the 4.0 version.

The new editor is awesome, but this upgrade forced me to re-export all of my assets and upgrade the spine-cpp runtime in my engine. Fortunately, the upgrade was as easy as checking out the 4.0 tag, and it built without so much as a compiler warning.

But this got me concerned about future compatibility issues.

  • Is there a place that I can download old versions of the editor? (or at least a stripped down export-only CLI)
  • Are there plans to add legacy/versioned export options to newer editors?

Without that, I'm basically forced to constantly update all of my projects with spine runtime releases, otherwise I lose the ability to rebuild my project from source in the future (unless I commit previously-exported assets, in which case I lose the ability to modify assets)
alexramallo
  • Сообщения: 2

Nate

The Spine launcher can always run all older versions of the Spine editor. If you'd like to continue using an older version, you can choose it on the new launcher screen:
Getting started - Spine User Guide: Running Spine

More on Spine versioning here:
Versioning - Spine User Guide

I assume with the old launcher you had the version set to "Latest" in Spine's settings. Now that 4.0 is the latest, your old launcher was unable to update to 4.0 and so gave you the message. Sorry the dialog shown didn't make things clear! The message is not very good -- it should not say "you must reinstall" but rather "you must reinstall to use Spine versions higher than 3.8.99, but you can continue using an older version if you like". We will make that change today. Edit: change has been made!

This will be a bit nicer with the new launcher. You can now choose the version on the launcher screen (or in the editor settings). I recommend choosing "Latest x.y" for the version you are using. Eg, "Latest 4.0" if you are using 4.0, "Latest 3.8" if you are using 3.8, etc. If you leave it at the default of just "Latest", then when 4.1 comes out it will prompt if you want to update to 4.1. You can say "no" and continue using the last version you were using. If you say "yes" you'll get 4.1 and then, since you moved up a major.minor version, you likely would need to update your runtimes.
Аватара пользователя
Nate

Nate
  • Сообщения: 11399

alexramallo

Wow, I didn't even know that was an option. That pretty much answers my question perfectly.

Thanks for the quick response!
alexramallo
  • Сообщения: 2


Вернуться в Runtimes