misaki_m

Hello,
Thank you for always answering my questions!
I have a question about "pack.json" today.

I read the following post :
Spine 3.8 Export attachments atlas maintaining image folders: p61182

It was just like what I want to do!
I use the option of "Image Folders" when I export JSON file, but I want to make TexturePacker ignores a specific folder.

I've tried to create pack.json and wrote the following:
{
ignore: true
}
I've put it in the images folder I want to exclusion, but it is not working...

Well, I've attached pack.json that I created, but I have no confidence because it is quite simple.

Please let me know how to set it.

Thanks in advance!
У вас нет необходимых прав для просмотра вложений в этом сообщении.
misaki_m
  • Сообщения: 53

Erika

Hello Misaki!

The file looks good, perhaps the problem is in how you are packing the images?
Did you try to use the texture packer from the dropdown menu here? Or were you perhaps packing when doing data export?


If you try, does it work or does it still export that folder?
Аватара пользователя
Erika

Erikari
  • Сообщения: 2548

misaki_m

Thank you for your reply, Erika!
I just tried it again now........ It was succeeded!!

I don't understand why it was not working at first...
However, it is working now both on JSON export, and using TexturePacker only.

I appreciate your quick answer and "pack.json"!
misaki_m
  • Сообщения: 53

Erika

Glad to hear it now works! :D
Аватара пользователя
Erika

Erikari
  • Сообщения: 2548

Nate

Note there are 2 ways to pack: 1) during data export, or 2) running the packer separately. If packing during data export, there are two options for how to pack: 1) attachments, or 2) image folders. When packing during data export and choosing attachments, Spine does not use the pack.json files. See here for more info:
Texture Packing - Spine User Guide
Аватара пользователя
Nate

Nate
  • Сообщения: 9845


Вернуться в Editor