Jamez0r

Hey guys, been using Spine for years now with Libgdx and now having a look at Unity. I'm going through the "Spine Examples/Getting Started/" section of the unitypackage, and the lighting in scene "5 Basic Platformer" doesn't seem to be working.

I started with a clean project, and didn't change anything besides importing the Spine unitypackage. I'd love to see it with the lighting - is there some newbie thing I need to do to enable it?



Thanks!

---

Note: I was using an older version of Unity when I took that screenshot - I updated Unity to the newest version, started a fresh project, imported the Spine package, and it still looks like the screenshot above
Jamez0r
  • Сообщения: 84

Harald

My first guess is that shadows are disabled in the active Quality Settings.
You can have a look here for reference: https://docs.unity3d.com/Manual/class-QualitySettings.html
Аватара пользователя
Harald

Harri
  • Сообщения: 1028

Jamez0r

Harald писал(а):My first guess is that shadows are disabled in the active Quality Settings.
You can have a look here for reference: https://docs.unity3d.com/Manual/class-QualitySettings.html
Thanks Harald, that was indeed the issue!

I'm new to Unity (obviously) and a bit confused by two things here: First off, the default quality was set to "Very Low" for all platforms. So I switched it to "Ultra", and despite it increasing values like Shadow Cascades, it still had "Shadows" set to Disabled? Seems strange, but I guess its just one of the things I'd have to customize.

Thanks for the help :)
Jamez0r
  • Сообщения: 84

Harald

Great to hear it worked, thanks for getting back to us! Yes, sometimes these settings can be somewhat strange.
Аватара пользователя
Harald

Harri
  • Сообщения: 1028

Jamez0r

Possibly due to starting the fresh project in "2D" mode rather than "3D"
Jamez0r
  • Сообщения: 84

Harald

Good point, that makes sense actually.
Аватара пользователя
Harald

Harri
  • Сообщения: 1028


Вернуться в Unity