tikitantrum

Minor issue, but would it possible to allow entry of floating point numbers less than one without first having to type a 0? I am re-exporting all my animations for 3.8 and I am continuously getting 5 instead of .5 in the pack settings/scale entry because it will only recognize the decimal character if I first enter a 0. So, if I type ".5", I scale my asset up 5x (because the '.' was not accepted), but if I type "0.5" it reduces by half.

I've encountered this numerous times over my time with the product but figured I'd bring it up now.
tikitantrum
  • Сообщения: 6

Erikari

Hello!
I tested the atlas export with a scale of .5 but it exported at half the size as expected. Do you perhaps have a reproduction project or steps that I can follow that would cause this to happen? If it's a file, you can send it to contact@esotericsoftware.com we'll keep it confidential.
Аватара пользователя
Erikari

Erikari
  • Сообщения: 1972

Nate

This was a bug with typing scale values in animate mode when auto key is enabled. It has been fixed in 3.8.60.
Аватара пользователя
Nate

Nate
  • Сообщения: 9241

tikitantrum

Thank you so much for looking at it! Sorry I missed your initial reply --- I was not getting notification emails.

---

Looks like it's still happening in 3.8.60 if there is already a number in the field that has a decimal point. Here is how I was able to reproduce it:

Create new project.
Go immediately to the export settings dialog.
Go to "Pack Settings"
Type in 5.0 in the first scale box
Select the "5.0" and attempt to type ".5" to replace it. It will not accept the "." when you type it.
tikitantrum
  • Сообщения: 6

Shiu

Thanks for the update and the reproduction steps. I've created an issue for it here: Entering decimal point in filled input field sometimes fails · #486 · EsotericSoftware/spine-editor

We should have a fix for this out soon!
Аватара пользователя
Shiu

Shiu
  • Сообщения: 2380


Вернуться в Editor