ara

hi,I'm using skeletondata modifier assets.
Spine-Unity SkeletonData Modifier Assets

It seems that runtime only detects Screen mode while Additive mode is missing.
The left side slot's blending mode is additive , right side slot's is screen.
in Spine:
spine.png

in Unity:
unity.png

I chose Default BlendModeMaterials asset. Shouldn't there be more materials like SkeletonPMAAdditive?
INFO.png


PS: I'm using unity 2018.3.0f2; my Spine-Unity runtime version is 3.7.xx
Maybe my setting is wrong, so I upload my project file, If there's something else I didn't notice please tell me. Thanks :)
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
ara
  • Сообщения: 47

Harald

Can you please check if Apply Additive Material is enabled at the Default BlendModeMaterials asset (or your own copy, whichever is used as your Skeleton Data Modifiers):

DefaultBlendModeMaterials_Inspector2.png

DefaultBlendModeMaterials_Project.png

DefaultBlendModeMaterials_Inspector.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Harald

Harri
  • Сообщения: 1105

ara

Harald писал(а):Can you please check if Apply Additive Material is enabled at the Default BlendModeMaterials asset (or your own copy, whichever is used as your Skeleton Data Modifiers):

DefaultBlendModeMaterials_Inspector2.png

DefaultBlendModeMaterials_Project.png

DefaultBlendModeMaterials_Inspector.png
That's it. Sorry for my missunderstanding :p
Аватара пользователя
ara
  • Сообщения: 47

Harald

No problem at all, glad it worked! :)
Аватара пользователя
Harald

Harri
  • Сообщения: 1105


Вернуться в Bugs