sumitkr99

Dear spine people, before 5 days spine is working perfectly but after that while i have imported all spine file(jason,atlas,texture) to my unity project it automatically created 3 extra file(SkeltonData,SkeltonAtlas,Material) which is previously we have to create manually. And after than animations are not working properly. please help me

Thanks
Sumit Kr
sumitkr99
  • Сообщения: 2

Pharan

What do you mean particularly by "animations are not working properly"?

It's possible that you had a very, very old version of the spine runtime.
Nobody has had to create SkeletonData, atlas and material set manually since the auto-import was implemented in July 2014. That's almost two years ago.

If that's the case, your exports may have been meant for that older runtime and not for a newer runtime, so what you possibly have to do is check your original spine projects and see if they work in Spine editor correctly. If they do, you can re-export them.
If not, you may have to edit them again, or choose keep using the older runtime.
Аватара пользователя
Pharan
  • Сообщения: 5366

sumitkr99

Hey! Thanks for reply and support, Here I am using latest spine version: 3.1.01, launcher: 3.0.03. but still I am facing same issue some time build auto import all data and some time it can't. But while I am using this animation some parts are not working in Unity Editor but inside the spine editor it's working perfectly . Here I have attached some snap of my Imported file. plz solve I cant able to move anymore.
Thanks
Sumit
У вас нет необходимых прав для просмотра вложений в этом сообщении.
sumitkr99
  • Сообщения: 2

Pharan

The screenshot doesn't give much information regarding what's wrong.
"some parts are not working" is a little vague.
I also don't understand what you mean by "some time build auto import all data and some time it can't"

Is this your problem? Method mix in Unity Mecanim
Аватара пользователя
Pharan
  • Сообщения: 5366


Вернуться в Unity