Aggressor

Howdy!

I've read up on the mix times: Applying Animations - Spine Runtimes Guide and I looked at a thread where someone had what seems like a similar issue: Animation transition problem

My problem is that when my unit switches idle poses, theres a stutter. There is a "Roar" idle and then the unit goes back to shuffling his arms and while his arms are shuffling hes supposed to transition to the "Idle" idle state and just keep shuffling his hands and loop indefinitely. My artist has assured me that the final frame from the end of the "Roar" idle is EXACTLY the same as the "Idle" idle 0 frame.

The problem is when going from the roar idle to the idle idle, theres a skip. When I set the mix time to 0, there is a micro stutter. And heres what it looks like if I set mix time to 0.5f (Ive slowed the animation down so you can see the stutter):



Note the stutter at the end is just the gif refreshing, the real issue is when his hands move up and down (right before the end), the transtions should be smooth. Setting the mix time to 0 just makes the above stutter happen at a micro flicker but its there.

Any suggestions on what I am missing?

My code is pretty bare bones:
_completeTrackListener = _baseState.SetAnimation(0, "idle", true);
_completeTrackListener.MixDuration = 0.5f;
Aggressor
  • Сообщения: 67

badlogic

This could have multiple causes, most likely it's a dipping issue (you can use that term to search here on the forum). We've put quite a lot of work into recent Spine Runtimes to alleviate this issue. Which version of the runtime are you using?
Аватара пользователя
badlogic

Mario
  • Сообщения: 2127

Aggressor

Ok I will search the forum for dipping.

We are using the most recent version of spine.
Aggressor
  • Сообщения: 67

badlogic

If you can create a simple Unity scene we can use to reproduce this issue we can take a look.
Аватара пользователя
badlogic

Mario
  • Сообщения: 2127

Aggressor

Ok give me some time and I will try to do this.

---

@badlogic After creating a test scene with only bare bones code, the sutter glitch disappeared so there must be some other bug in my animation logic. I will spend some more time and look and see if there is an errant call occurring that is briefly changing the animation.
Aggressor
  • Сообщения: 67


Вернуться в Unity