Nicky

Hello,
I'm still in the learning process using spine. I had to downgrade to the version 3.7.94 because gamemaker 2 doesn't agree with the json files from the most recent version. The issue comes when i'm making an animation in spine. Instead of having the software "fill" the intervals between each pose, it just switches between the poses in a robotic manner. This is really unlike the more recent version where everything is smoothed automatically. Is this a change that happened later, or is there a box i need to tick?

Thank you for you time and you help!
Nicky
  • Сообщения: 8

Nate

Sounds like you have enabled Stepped on the Playback view.
Playback - Spine User Guide: Stepped
Аватара пользователя
Nate

Nate
  • Сообщения: 10750

Nicky

Hello Nate, thank you for your quick answer.
I tried that, but it's not making any difference sadly. i tried different settings and it doesn't work. Restarting the software, the setting is not saved either. Is there an "ok" button to actually activate the change that i'm not seeing? Sorry for these questions, this all seems very basic understanding, but i't really confusing to me.
Nicky
  • Сообщения: 8

Nate

Could it be that your keys are stepped? If so they'll have a dashed line between them in the dopesheet.
Graph - Spine User Guide: Stepped
Аватара пользователя
Nate

Nate
  • Сообщения: 10750

Nicky

Ah, I found the issue. I had to set a first key frame for every bone manually. It seemed to me that it worked a bit differently on a more recent update. Without the first key frame set, it created a stepped key by default. Or at least that's how i'm understanding what i did wrong!
Thank you for your help :)
Nicky
  • Сообщения: 8

Nate

Ah, glad you figured it out! It has always been that way, you get the setup pose before the first key, then it changes instantly at the key.
Аватара пользователя
Nate

Nate
  • Сообщения: 10750

Nicky

Noted, thanks a lot! Still have a lot to learn!
Nicky
  • Сообщения: 8


Вернуться в Runtimes