leshido

Trying to export skeleton animations for multiple skins and animations, using "create atlas", only exports the currently selected animation and skin.
leshido
  • Сообщения: 2

Nate

I guess you are exporting image sequences? I've added an option to export the current skin (old behavior) or all skins when exporting image sequences (in 1.5.23).
Аватара пользователя
Nate

Nate
  • Сообщения: 9286

Captain510

Nate писал(а):I guess you are exporting image sequences? I've added an option to export the current skin (old behavior) or all skins when exporting image sequences (in 1.5.23).
Hi, Nate. I got the same problem. When I export my animation ,now only add current animation but not all animations.
And I tried to change options in export panel, but no configs can export all animations in a single json file...

Can you give me a right config for this ?
Captain510
  • Сообщения: 13

Nate

To be clear, the OP doesn't have a problem -- there was never a feature to export all skins. This was just added.

@Captain510, your image didn't work. Did you choose type sequence and animations all?


"no configs can export all animations in a single json file" <- This doesn't make sense. This thread is about exporting images. If you export JSON then all animations are always in the JSON.
Аватара пользователя
Nate

Nate
  • Сообщения: 9286

Captain510

Nate писал(а):To be clear, the OP doesn't have a problem -- there was never a feature to export all skins. This was just added.

@Captain510, your image didn't work. Did you choose type sequence and animations all?


"no configs can export all animations in a single json file" <- This doesn't make sense. This thread is about exporting images. If you export JSON then all animations are always in the JSON.
Yes, I tried the configs in your screenshot(I just updated to 1.5.24), and it will export like this:

this is my config

And If I don't check "create atlas", then will create more images for each animations

And many images are missing.

I just make simple 2d sprite animations now(no bone for now), I add many images to root slot, and I just change image in different frames to make simple animation. And When I was in 1.5.21, exporting is simply export JSON with "create atlas" checked, I do not need to set anything in PNG panel. What I used to have is a single png, a single json, a single atlas. now are a lot of png and atlas.So can you take a look at this problem?

Best regards,
Captain510
  • Сообщения: 13

Nate

Your screenshots don't show up. I can't understand what the issue is, sorry.
Аватара пользователя
Nate

Nate
  • Сообщения: 9286

Captain510

I update the images, can you see by now?
Captain510
  • Сообщения: 13

Nate

Ah I see, you are getting missing images when exporting images. Not good! I have a fix but it is mixed in with other changes that aren't quite ready to deploy yet. I'll hopefully upload a fixed version today, maybe tomorrow. Sorry!
Аватара пользователя
Nate

Nate
  • Сообщения: 9286

Captain510

Nate писал(а):Ah I see, you are getting missing images when exporting images. Not good! I have a fix but it is mixed in with other changes that aren't quite ready to deploy yet. I'll hopefully upload a fixed version today, maybe tomorrow. Sorry!
I just stay in 1.5.21, everything works fine~~Thanks for your hardwork anyway
Captain510
  • Сообщения: 13

Nate

1.5.27 is now up, can you try with that?
Аватара пользователя
Nate

Nate
  • Сообщения: 9286

Captain510

Nate писал(а):1.5.27 is now up, can you try with that?
Now everything goes back to normal~Thanks!
Captain510
  • Сообщения: 13


Вернуться в Bugs