truncoat

目前项目在unity5.4.3版本下开发,美术用了spine最新版本做的素材导入后提示版本不对 想问下是需要用旧版本的spine来处理素材吗 如果的是的话 请问 在哪下载spine的历代旧版本
Skeleton 'NPC_23.skel' (exported with Spine 3.8.85) may be incompatible with your runtime version: spine-unity v3.5
UnityEngine.Debug:LogWarningFormat(String, Object[])
Spine.Unity.Editor.SpineEditorUtilities:IsSpineData(TextAsset) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:1248)
Spine.Unity.Editor.SpineEditorUtilities:ImportSpineContent(String[], Boolean) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:576)
Spine.Unity.Editor.SpineEditorUtilities:OnPostprocessAllAssets(String[], String[], String[], String[]) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:549)
UnityEditor.AssetPostprocessingInternal:PostprocessAllAssets(String[], String[], String[], String[], String[])
IndexOutOfRangeException: Array index is out of range.
Spine.SkeletonBinary.ReadSkeletonData (System.IO.Stream input) (at Assets/spine-csharp/SkeletonBinary.cs:170)
Spine.Unity.Editor.SpineEditorUtilities.AddRequiredAtlasRegionsFromBinary (System.String skeletonDataPath, System.Collections.Generic.List`1 requiredPaths) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:817)
Spine.Unity.Editor.SpineEditorUtilities.GetRequiredAtlasRegions (System.String skeletonDataPath) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:825)
Spine.Unity.Editor.SpineEditorUtilities.ImportSpineContent (System.String[] imported, Boolean reimport) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:605)
Spine.Unity.Editor.SpineEditorUtilities.OnPostprocessAllAssets (System.String[] imported, System.String[] deleted, System.String[] moved, System.String[] movedFromAssetPaths) (at Assets/spine-unity/Editor/SpineEditorUtilities.cs:549)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:232)
System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MethodBase.cs:115)
UnityEditor.AssetPostprocessingInternal.PostprocessAllAssets (System.String[] importedAssets, System.String[] addedAssets, System.String[] deletedAssets, System.String[] movedAssets, System.String[] movedFromPathAssets) (at C:/buildslave/unity/build/Editor/Mono/AssetPostprocessor.cs:27)
truncoat
  • Сообщения: 6

Harald

入后提示版本不对 想问下是需要用旧版本的spine来处理素材吗 如果的
是的,如果您无法更新Unity,则需要使用旧版本的Spine。
Yes, you need to use an older version of Spine if you cannot update Unity.
是的话 请问 在哪下载spine的历代旧版本
您需要使用最新的SpineLauncher,但可以通过Spine-Settings-Version从Spine切换到旧的Spine版本:
Settings - Spine User Guide: Settings

在这里,您可以找到适合您的Spine旧版本的列表:
Spine: Changelog: v3.6

您还可以在此处查看Unity 5.4的兼容spine-unity版本:
Spine Unity Download: Older Versions
---
You need to use the latest Spine Launcher , but can switch to an old Spine version from Spine via Spine - Settings - Version:
Settings - Spine User Guide: Settings

Here you can find a list of old Spine versions that should be suitable for you:
Spine: Changelog: v3.6

You can also have a look at the compatible spine-unity versions for Unity 5.4 here:
Spine Unity Download: Older Versions
Аватара пользователя
Harald

Harri
  • Сообщения: 1971


Вернуться в 中国Spine用户