scq3504168

因为项目周期长中间用了两个版本,导致现在新旧版本不能同时兼容

---

没有人知道怎么解决么
У вас нет необходимых прав для просмотра вложений в этом сообщении.
scq3504168
  • Сообщения: 1

Harald

我是否正确理解了您要同时使用多个Spine(和spine-unity)版本的问题? 如果是,那么答案是不幸的是这是不可能的。
Did I understand your question correctly, that you want to use multiple Spine (and spine-unity) versions at the same time? If yes, then the answer is that this is unfortunately not possible.

如果您只是升级了Spine编辑器而没有升级spine-unity运行时,则仅是spine-unity运行时版本必须与Spine Editor版本匹配。
If you just upgraded the Spine Editor and have not upgraded the spine-unity runtime, then it's simply that spine-unity runtime version has to match the Spine Editor version.

请注意,Spine-Unity运行时版本(例如3.8)必须与用于导出骨架文件的Spine Editor版本(例如3.8.62)匹配。 当主要+次要版本号不匹配(3.5 vs 3.8)时,由于格式不兼容,Unity中的导入将失败。
Please note that the Spine-Unity runtime version (e.g. 3.8 ) has to match the Spine Editor version (e.g. 3.8.62) which was used to export your skeleton files. When major+minor version numbers do not match (3.5 vs 3.8 ) as in your case, import in Unity will fail due to format incompatibility.

因此,如果要使用Spine-Unity运行时版本3.8,则必须从Spine 3.8重新导出资产。
请注意,您可以使用批处理导出通过命令行界面快速重新导出所有骨架:
Export - Spine User Guide: Command line
So if you want to use Spine-Unity runtime version 3.8, you have to reexport your assets from Spine 3.8.
Note that you can use batch-export to re-export all your skeletons quickly via the command line interface:
Export - Spine User Guide: Command line
Аватара пользователя
Harald

Harri
  • Сообщения: 1105


Вернуться в 中国Spine用户